Archived
1
0

v1.1 update - stable

this version will run with npm start, but when attempting to run the built version behind nginx, it appears to have issues
This commit is contained in:
Sean Edmunds
2021-12-15 01:48:50 +00:00
parent c5bc63dc54
commit 3e953ad8d2
2731 changed files with 140242 additions and 1139679 deletions

101
node_modules/uri-js/package.json generated vendored
View File

@@ -1,9 +1,54 @@
{
"name": "uri-js",
"version": "4.4.1",
"_from": "uri-js@4.4.1",
"_id": "uri-js@4.4.1",
"_inBundle": false,
"_integrity": "sha512-7rKUyy33Q1yc98pQ1DAmLtwX109F7TIfWlW1Ydo8Wl1ii1SeHieeh0HHfPeL2fMXK6z0s8ecKs9frCuLJvndBg==",
"_location": "/uri-js",
"_phantomChildren": {},
"_requested": {
"type": "version",
"registry": true,
"raw": "uri-js@4.4.1",
"name": "uri-js",
"escapedName": "uri-js",
"rawSpec": "4.4.1",
"saveSpec": null,
"fetchSpec": "4.4.1"
},
"_requiredBy": [
"/ajv",
"/table/ajv"
],
"_resolved": "https://registry.npmjs.org/uri-js/-/uri-js-4.4.1.tgz",
"_shasum": "9b1a52595225859e55f669d928f88c6c57f2a77e",
"_spec": "uri-js@4.4.1",
"_where": "/home/magnum/home-page",
"author": {
"name": "Gary Court",
"email": "gary.court@gmail.com"
},
"bugs": {
"url": "https://github.com/garycourt/uri-js/issues"
},
"bundleDependencies": false,
"dependencies": {
"punycode": "^2.1.0"
},
"deprecated": false,
"description": "An RFC 3986/3987 compliant, scheme extendable URI/IRI parsing/validating/resolving library for JavaScript.",
"main": "dist/es5/uri.all.js",
"types": "dist/es5/uri.all.d.ts",
"devDependencies": {
"babel-cli": "^6.26.0",
"babel-plugin-external-helpers": "^6.22.0",
"babel-preset-latest": "^6.24.1",
"mocha": "^8.2.1",
"mocha-qunit-ui": "^0.1.3",
"rollup": "^0.41.6",
"rollup-plugin-babel": "^2.7.1",
"rollup-plugin-node-resolve": "^2.0.0",
"sorcery": "^0.10.0",
"typescript": "^2.8.1",
"uglify-js": "^2.8.14"
},
"directories": {
"test": "tests"
},
@@ -15,19 +60,7 @@
"CHANGELOG",
"LICENSE"
],
"scripts": {
"build:esnext": "tsc",
"build:es5": "rollup -c && cp dist/esnext/uri.d.ts dist/es5/uri.all.d.ts && npm run build:es5:fix-sourcemap",
"build:es5:fix-sourcemap": "sorcery -i dist/es5/uri.all.js",
"build:es5:min": "uglifyjs dist/es5/uri.all.js --support-ie8 --output dist/es5/uri.all.min.js --in-source-map dist/es5/uri.all.js.map --source-map uri.all.min.js.map --comments --compress --mangle --pure-funcs merge subexp && mv uri.all.min.js.map dist/es5/ && cp dist/es5/uri.all.d.ts dist/es5/uri.all.min.d.ts",
"build": "npm run build:esnext && npm run build:es5 && npm run build:es5:min",
"clean": "rm -rf dist",
"test": "mocha -u mocha-qunit-ui dist/es5/uri.all.js tests/tests.js"
},
"repository": {
"type": "git",
"url": "http://github.com/garycourt/uri-js"
},
"homepage": "https://github.com/garycourt/uri-js",
"keywords": [
"URI",
"IRI",
@@ -52,26 +85,22 @@
"RFC6455",
"RFC6874"
],
"author": "Gary Court <gary.court@gmail.com>",
"license": "BSD-2-Clause",
"bugs": {
"url": "https://github.com/garycourt/uri-js/issues"
"main": "dist/es5/uri.all.js",
"name": "uri-js",
"repository": {
"type": "git",
"url": "git+ssh://git@github.com/garycourt/uri-js.git"
},
"homepage": "https://github.com/garycourt/uri-js",
"devDependencies": {
"babel-cli": "^6.26.0",
"babel-plugin-external-helpers": "^6.22.0",
"babel-preset-latest": "^6.24.1",
"mocha": "^8.2.1",
"mocha-qunit-ui": "^0.1.3",
"rollup": "^0.41.6",
"rollup-plugin-babel": "^2.7.1",
"rollup-plugin-node-resolve": "^2.0.0",
"sorcery": "^0.10.0",
"typescript": "^2.8.1",
"uglify-js": "^2.8.14"
"scripts": {
"build": "npm run build:esnext && npm run build:es5 && npm run build:es5:min",
"build:es5": "rollup -c && cp dist/esnext/uri.d.ts dist/es5/uri.all.d.ts && npm run build:es5:fix-sourcemap",
"build:es5:fix-sourcemap": "sorcery -i dist/es5/uri.all.js",
"build:es5:min": "uglifyjs dist/es5/uri.all.js --support-ie8 --output dist/es5/uri.all.min.js --in-source-map dist/es5/uri.all.js.map --source-map uri.all.min.js.map --comments --compress --mangle --pure-funcs merge subexp && mv uri.all.min.js.map dist/es5/ && cp dist/es5/uri.all.d.ts dist/es5/uri.all.min.d.ts",
"build:esnext": "tsc",
"clean": "rm -rf dist",
"test": "mocha -u mocha-qunit-ui dist/es5/uri.all.js tests/tests.js"
},
"dependencies": {
"punycode": "^2.1.0"
}
"types": "dist/es5/uri.all.d.ts",
"version": "4.4.1"
}